加入收藏 | 设为首页 | 会员中心 | 我要投稿 衡阳站长网 (https://www.0734zz.cn/)- 数据集成、设备管理、备份、数据加密、智能搜索!
当前位置: 首页 > 大数据 > 正文

POJ 1001 Exponentiation(大数幂,还是Java大发好!需调用多个方法

发布时间:2021-03-14 02:04:17 所属栏目:大数据 来源:网络整理
导读:Exponentiation Time Limit: ?500MS ? Memory Limit: ?10000K Total Submissions: ?156303 ? Accepted: ?38063 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example,the comput

Exponentiation

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example,the computation of the national debt is a taxing experience for many computer systems.?

This problem requires that you write a program to compute the exact value of R n?where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6,and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input:?
s?is a string and? n?is an integer?
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want

/*while(scanf(%s%d",&n)!=EOF) //this also work    */

{

...

}

Source

East Central North America 1988
原题链接:http://poj.org/problem?id=1001
题意:输入两个数x,y,求x^y,(y为整型),结果小于0,输出的结果去掉前面的"0.",直接输出后面的.
这题和以前的一题差不多,http://www.voidcn.com/article/p-ewdskowo-cz.html 如: stripTrailingZeros() toPlainString(); 调用的方法也差不多,但这题如果结果小于小于0,要去掉前导"0.",那该怎么做呢 ? 把结果转换成string类型,再调用java.lang.string类中的substring()方法就OK了. API中 substring() 方法的说明:
public String substring(int beginIndex) 返回一个新的字符串,它是此字符串的一个子字符串。 该子字符串从指定索引处的字符开始,
直到此字符串末尾。
示例:?
? "unhappy".substring(2) returns "happy"
? "Harbison".substring(3) returns "bison"
? "emptiness".substring(9) returns "" (an empty string)
参数:
beginIndex - 起始索引(包括)。?
返回:
指定的子字符串。?
抛出:?
IndexOutOfBoundsException - 如果 beginIndex 为负或大于此 String 对象的长度。
substring
public String substring(int beginIndex,int endIndex) 返回一个新字符串,它是此字符串的一个子字符串。 该子字符串从指定的 beginIndex 处开始,直到索引 endIndex - 1 处的字符。 因此,该子字符串的长度为 endIndex-beginIndex。?
示例:?
? "hamburger".substring(4,8) returns "urge"
? "smiles".substring(1,5) returns "mile"
参数:
beginIndex - 起始索引(包括)。
endIndex - 结束索引(不包括)。?
返回:
指定的子字符串。?
抛出:?
IndexOutOfBoundsException - 如果 beginIndex 为负,或 endIndex 大于此 String 对象的长度, 或 beginIndex 大于 endIndex。

AC代码:

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {

		Scanner sc = new Scanner(System.in);
		while (sc.hasNext()) {
			BigDecimal a = sc.nextBigDecimal();
			int b = sc.nextInt();
			a = a.pow(b);
			String str = a.stripTrailingZeros().toPlainString();
			if (str.startsWith("0.")){
				str = str.substring(1);
			}
			System.out.println(str);
		}
	}

}

(编辑:衡阳站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读